Staršie aplikácie nemusia fungovať na Android P korektne. Niektoré sa možno ani nespustia

0

Vývojári našli novú klasifikáciu pre aplikácie v poslednom náhľade Android P Dev Preview, ktorý nastavuje minimálnu verziu rozhrania API. Ak ju aplikácia nesplní, objaví sa systémová hláška s varovaním:

Táto aplikácia bola vytvorená pre staršiu verziu systému Android a nemusí fungovať správne. Skúste vyhľadať aktualizácie alebo kontaktujte vývojára.

Aktuálne je minimálna verzia API pre Android P požadovaná aspoň vo verzii 17, čo zodpovedá Android 4.2 Jelly Bean. Pravdepodobne sa bude jednať o nastavenie API pre Dev Preview v Android P. Je ale pravdepodobné, že so snahami Google vylepšovať systém a zvyšovať bezpečnosť je to finálne riešenie od Google. Uvidíme teda, či sa toto nastavenie API prenesie aj do konečnej verzie Android P. My to vnímame ako logický krok.

Spoločnosť Google už preukázala svoje odhodlanie aktualizovať aplikácie Obchodu Play pomocou nastavenia minimálnej požiadavky na podporu API pre novo nahrané aplikácie. Týmto spôsobom by všetky novo odoslané aplikácie mali fungovať iba s najnovšími verziami systému Android. Zatiaľ čo tie, ktoré sú už vydané a nebudú sa aktualizovať, tak tie budú zrušené a vymazané.

Spoločnosť Apple už tento krok nedávno spravila a vyčistila svoj App Store. Pokiaľ sa pokúsite takto zrušenú aplikáciu spustiť zo zálohy iCloud, zobrazí sa buď varovná správa, alebo k spusteniu vôbec nepríde.

Google nám postupne otvára svoj pohľad na Android P, a my ho budeme sledovať.

zdroj: gsmarena

Prečítajte si aj:

Google predstavil nový Android P. Prináša podporu výrezu či API pre viac kamier

O autorovi

Každý deň sledujem aktuálne dianie v technologickom svete a vyberám tie najzaujímavejšie témy pre náš web. Zaujímam sa o smartfóny, aplikácie, gadgety, nositeľnú elektroniku a technologické vízie. Medzi moje najobľúbenejšie voľnočasové aktivity patrí šport, hudba a moje štyri dcéry.

Pridaj komentár